[传奇教程] 第二课-服务器和网关对接,TOKEN验证及算法,微信公众号传奇网关

  [复制链接]
查看6738 | 回复88 | 2018-7-13 15:03:04 | 显示全部楼层 |阅读模式
第二课-服务器和网关对接,TOKEN验证及算法。
------------------------------------TOKEN源码
.子程序 TOKEN验证
.参数 GET数据, 文本型
.参数 当前客户, 文本型
.局部变量 字符验证, 文本型
.局部变量 GET分割, 文本型, , "0"
.局部变量 数组重新排序, 文本型, , "0"
.局部变量 验证码, 文本型
.局部变量 数据加密, 类_数据操作
.局部变量 数据对比, 文本型

字符验证 = 子文本替换 (GET数据, “signature=”, “”, , , 真)
字符验证 = 子文本替换 (字符验证, “echostr=”, “”, , , 真)
字符验证 = 子文本替换 (字符验证, “timestamp=”, “”, , , 真)
字符验证 = 子文本替换 (字符验证, “nonce=”, “”, , , 真)
.如果真 (寻找文本 (字符验证, “&”, , 假) = -1)
    日志输出 (“TOKEN验证失败..”)
    返回 ()
.如果真结束
GET分割 = 分割文本 (字符验证, “&”, )
加入成员 (数组重新排序, GET分割 [3])
加入成员 (数组重新排序, GET分割 [4])
加入成员 (数组重新排序, _启动窗口.编辑框_微信接口_TOKEN.内容)
数组_排序 (数组重新排序, , )
验证码 = 数组重新排序 [1] + 数组重新排序 [2] + 数组重新排序 [3]
数据对比 = 数据加密.hex_sha1 (到字节集 (验证码))
.如果真 (GET分割 [1] = 数据对比)
    日志输出 (“TOKEN验证成功...”)
    服务器返回数据 (当前客户, #wx_协议头 + 时间_转为GMT格式 (取现行时间 ()) + #换行符 + #换行符 + GET分割 [2])
    返回 ()
.如果真结束
日志输出 (“TOKEN验证失败...”)
服务器返回数据 (当前客户, GET分割 [1])

11.png

------------------------------------
第三课-用户关注触发及保存用户信息到数据库。

游客,传奇服务端,传奇版本,传奇GM论坛提示:本站大部分资源回复即可下载回复帖子









上一篇:第一课-易语言安装和公众号基本介绍-微信公众号传奇网关
下一篇:传奇微信公众号第3课-用户关注触发及保存用户信息到数据库
回复

使用道具 举报

秋意 | 2018-7-13 17:13:55 | 显示全部楼层
我 要下载
回复

使用道具 举报

a123456 | 2018-7-19 21:37:20 | 显示全部楼层
这个可以.....支持
回复 支持 反对

使用道具 举报

zhanghua | 2018-7-24 17:54:00 | 显示全部楼层
给嘎嘎嘎嘎嘎嘎嘎嘎嘎嘎嘎嘎嘎嘎嘎嘎
回复 支持 反对

使用道具 举报

sunchong | 2018-8-4 17:48:15 | 显示全部楼层
露露桎爱你,,,支持坛主
回复 支持 反对

使用道具 举报

10077900 | 2018-8-5 21:33:32 | 显示全部楼层
asdadadada
回复 支持 反对

使用道具 举报

yvcd125 | 2018-8-7 22:00:44 | 显示全部楼层
支持支持 好东西
回复 支持 反对

使用道具 举报

shenbinbl | 2018-8-8 18:08:58 | 显示全部楼层
看了一半没有了?
回复 支持 反对

使用道具 举报

宁以静远 | 2018-8-9 19:04:24 | 显示全部楼层
第二课-服务器和网关对接,TOKEN验证及算法,微信公众号传奇网关  看看
回复 支持 反对

使用道具 举报

d81010529y | 2018-8-16 13:57:56 | 显示全部楼层
看看什么啊啊 啊
回复 支持 反对

使用道具 举报

本版积分规则