[传奇教程] 传奇微信公众号第3课-用户关注触发及保存用户信息到数据库

[复制链接]
查看7362 | 回复26 | 2018-7-14 13:50:49 | 显示全部楼层 |阅读模式
第三课-用户关注触发及保存用户信息到数据库。
-----------------重点-------------------
关注事件和 取消关注事件 判断代码:

.如果真 (XML参数.消息类型 = “event”)
    .如果真 (XML参数.事件类型 = “subscribe”)
        日志输出 (“新用户[” + XML参数.OpenID + “]关注公众号....”)
        服务器返回数据 (当前客户, “ ”)
        SQL = “insert into Wx_User(OPENID,积分,元宝) values ('” + XML参数.OpenID + “','” + “2” + “ ','” + “10” + “') ”
        数据库写入 (SQL)
    .如果真结束
    .如果真 (XML参数.事件类型 = “unsubscribe”)
        日志输出 (“新用户[” + XML参数.OpenID + “]不在关注公众号....”)
        服务器返回数据 (当前客户, “ ”)


SQL语句格式:

SQL = “insert into Wx_User(OPENID,积分,元宝) values ('” + XML参数.OpenID + “','” + “2” + “ ','” + “10” + “') ”
------------------------------------
access数据库下载:https://www.diygm.com/thread-828-1-1.html

第四课-用户文本消息处理及回复。

教程下载地址传奇微信公众号开发:3.用户关注及写入数据库









上一篇:第二课-服务器和网关对接,TOKEN验证及算法,微信公众号传奇网关
下一篇:第4课,传奇微信公众号,微信用户文本消息处理及回复
回复

使用道具 举报

a123456 | 2018-7-19 21:37:43 | 显示全部楼层
这个可以.....支持
回复 支持 反对

使用道具 举报

sunchong | 2018-8-4 17:51:35 | 显示全部楼层
露露桎爱你,,,支持坛主
回复 支持 反对

使用道具 举报

宁以静远 | 2018-8-11 14:37:27 | 显示全部楼层
我滴哥 想给你送钱 都送不了 没法充值
回复 支持 反对

使用道具 举报

dlyywqf | 2018-8-13 23:01:05 | 显示全部楼层
新用户没金币
回复 支持 反对

使用道具 举报

hz12366 | 2018-8-17 20:59:11 | 显示全部楼层
没有足够的金币下载,这就比较尴尬了
回复 支持 反对

使用道具 举报

hz12366 | 2018-8-17 21:11:45 | 显示全部楼层
还差10来个金币
回复 支持 反对

使用道具 举报

hz12366 | 2018-8-17 21:23:55 | 显示全部楼层
搞不定啊 服务不可用
回复 支持 反对

使用道具 举报

hz12366 | 2018-8-17 21:31:14 | 显示全部楼层
这课下载就完事儿了
回复 支持 反对

使用道具 举报

baya1234 | 2018-9-1 15:33:02 | 显示全部楼层
开始收钱了
回复 支持 反对

使用道具 举报

本版积分规则