[传奇教程] 第六课,主网关和副网关的数据通信_易语言开发微信公众号传奇网关

[复制链接]
查看3647 | 回复8 | 2018-7-27 00:06:12 | 显示全部楼层 |阅读模式
第六课:主网关和副网关的数据通信
----------------------------------------------------
当前客户 = 服务器.取回客户 ()
.如果真 (寻找文本 (到文本 (服务器.取回数据 ()), “<xml>”, , 假) < -1)
    日志输出 (“收到非法数据.已端口用户[” + 当前客户 + “]连接...”)
    返回 ()
.如果真结束
xml.导入 (服务器.取回数据 ())
' 日志输出 (到文本 (xml.取XML数据 (, , , )))
.如果真 (xml.取节点值文本 (“xml/key”, ) = 编辑框_KEY.内容)
    日志输出 (“密钥:” + xml.取节点值文本 (“xml/key”, ) + “ 账号:” + xml.取节点值文本 (“xml/账号”, ) + “ 名称:” + xml.取节点值文本 (“xml/名称”, ))
    服务器.发送数据 (当前客户, “OK”, )
    返回 ()
.如果真结束
日志输出 (“密钥错误:” + xml.取节点值文本 (“xml/key”, ))
服务器.发送数据 (当前客户, “NO”, )

记录集.打开 (“SELECT * FROM fwq WHERE 名称 = '” + “176金币5区” + “'”, #SQL语句, )
记录集.读文本 (“名称”, 名称)
.如果真 (名称 = “176金币5区”)
    记录集.读文本 (“IP”, IP地址)
    记录集.读文本 (“端口”, 端口)
    记录集.读文本 (“密钥”, 密钥)
    记录集.读文本 (“路径”, 路径)
    日志输出 (密钥)
    xml.创建 (“xml”)
    xml.插入节点 (“xml”, “key”, 密钥, 真)
    xml.插入节点 (“xml”, “Type”, “新人礼包”, 真)
    xml.插入节点 (“xml”, “名称”, 名称, 真)
    xml.插入节点 (“xml”, “账号”, “abc123”, 真)
    xml.插入节点 (“xml”, “路径”, 路径, 真)
    客户发送数据 (IP地址, 到短整数 (端口), 到文本 (xml.取XML数据 (, , , )))
    返回 ()
.如果真结束
日志输出 (“未找到该分区...” + 名称)
----------------------------------------------------
第七课:主网关向服务端发送元宝,物品等物品
1.png.jpg

教程源码附件下载传奇微信公众号开发:6.主和副网关数据通信






上一篇:第五课:完善1到4课的一些小问题_易语言开发微信公众号传奇网关
下一篇:易语言开发微信公众号传奇网关_第七课,主网关向服务端发送元宝,物品等物品
回复

使用道具 举报

10077900 | 2018-7-29 17:40:12 | 显示全部楼层
第六课,主网关和副网关的数据通信_易语言开发微信公众号传奇网关
回复 支持 反对

使用道具 举报

sunchong | 2018-8-4 18:08:45 | 显示全部楼层
露露桎爱你,,,支持坛主,,金币不够了
回复 支持 反对

使用道具 举报

hz12366 | 2018-8-17 21:26:23 | 显示全部楼层
金钱24.还差3个帖子
回复 支持 反对

使用道具 举报

hz12366 | 2018-8-17 21:28:22 | 显示全部楼层
还差4个金币
回复 支持 反对

使用道具 举报

baya1234 | 2018-9-1 15:35:05 | 显示全部楼层
留GE脚印方便以后寻找吧
回复 支持 反对

使用道具 举报

wen1 | 2018-9-19 16:19:44 | 显示全部楼层
回复

使用道具 举报

含笑一生 | 2018-9-29 16:57:49 | 显示全部楼层
主网关和副网关的数据通信_易语言开发微信公众号传奇网关
回复 支持 反对

使用道具 举报

zjjcl | 2019-7-8 14:17:59 | 显示全部楼层
1111111111111111111
回复 支持 反对

使用道具 举报

本版积分规则