[传奇教程] 易语言开发微信公众号传奇网关_第七课,主网关向服务端发送元宝,物品等物品

[复制链接]
查看6519 | 回复10 | 2018-7-28 09:53:35 | 显示全部楼层 |阅读模式
第七课:主网关向服务端发送元宝,物品等物品
相关重要代码:
.如果真 (xml.取节点值文本 (“xml/Type”, ) = “关注礼包”)
    游戏路径 = xml.取节点值文本 (“xml/路径”, ) + “\Mir200\Envir\QuestDiary\微信系统\关注礼包.txt”
    写到文件 (游戏路径, 读入文件 (游戏路径) + 到字节集 (#换行符 + xml.取节点值文本 (“xml/账号”, )))
    日志输出 (“分区[” + xml.取节点值文本 (“xml/名称”, ) + “]玩家[” + xml.取节点值文本 (“xml/账号”, ) + “]领取了关注礼包...”)
    返回 ()
.如果真结束
.如果真 (xml.取节点值文本 (“xml/Type”, ) = “游戏充值”)
    游戏路径 = xml.取节点值文本 (“xml/路径”, ) + “\Mir200\Envir\QuestDiary\微信系统\元宝领取\”
    N1 = xml.取节点值文本 (“xml/数量”, )
    .判断循环首 (N < 取文本长度 (N1))
        .如果真 (取文本中间 (N1, 取文本长度 (N1) - N, 1) ≠ “0”)
            写到文件 (游戏路径 + 取文本中间 (N1, 取文本长度 (N1) - N, 1) + 零补位 + “.txt”, 到字节集 (xml.取节点值文本 (“xml/账号”, )) + 到字节集 (#换行符) + 到字节集 (读入文件 (游戏路径 + 取文本中间 (N1, 取文本长度 (N1) - N, 1) + 零补位 + “.txt”)))
        .如果真结束
        零补位 = 零补位 + “0”
        N = N + 1
        日志输出 (游戏路径 + 取文本中间 (N1, 取文本长度 (N1) - N, 1) + 零补位 + “.txt”)
    .判断循环尾 ()
    日志输出 (“分区[” + xml.取节点值文本 (“xml/名称”, ) + “]玩家[” + xml.取节点值文本 (“xml/账号”, ) + “]兑换了[” + xml.取节点值文本 (“xml/数量”, ) + “]元宝...”)
----------------------------------------------------
第八课:微信用户向服务端发送数据
1.png.jpg
易语言开发微信公众号传奇网关视频教程转移到新论坛地址https://www.diygm.com/thread-864-1-1.html






上一篇:第六课,主网关和副网关的数据通信_易语言开发微信公众号传奇网关
下一篇:[十天入门易语言]第一课:易语言基本知识_易语言视频教程下载
回复

使用道具 举报

10077900 | 2018-7-29 17:38:29 | 显示全部楼层
金币充值不了~~~
回复 支持 反对

使用道具 举报

sunchong | 2018-8-4 18:12:59 | 显示全部楼层
露露桎爱你,,支持坛主,金币不够了
回复 支持 反对

使用道具 举报

九千岁 | 2018-8-15 07:59:05 | 显示全部楼层
看下,感谢🙏楼主大神
回复 支持 反对

使用道具 举报

d81010529y | 2018-8-16 14:00:07 | 显示全部楼层
学习学习是什么
回复 支持 反对

使用道具 举报

dlyywqf | 2018-8-21 16:03:20 | 显示全部楼层

看下,感谢🙏楼主大神
回复 支持 反对

使用道具 举报

baya1234 | 2018-9-1 15:35:39 | 显示全部楼层
最后一课 留给脚印方便以后寻找吧
回复 支持 反对

使用道具 举报

黑色的星期天 | 2018-9-18 10:44:21 | 显示全部楼层
格式: OPENMERCHANTBIGDLG WIL文件序号 图片序号 是否可以移动(0,1) 显示位置(0=左上角,1=右上角,2=左下角,3=右下角,4=居中) 微调坐标X 微调坐标Y 是否显示关闭按钮(0,1) 关闭按钮坐标X 关闭按钮坐标Y
例:
[@main]
#ACT
OPENMERCHANTBIGDLG 3 607 0 1 1 1 1
;根据下图中的WIL序号,3表示的是prguse2.wzl,WIL序号的计算是从0开始的,从0开始数prguse2.wzl在第三位,
;如果要调用其他素材,如果WIL资料里没有,可以先添加WIL文件到WIL资源列表,然后修改脚本的WIL文件序号,就可以调用对应的文件。
;这个脚本调用的是prguse2.wzl素材里的607这个素材,为NPC的对话框
什么是WIL文件序号?
具体可以在,M2-查看-列表信息二
回复 支持 反对

使用道具 举报

黑色的星期天 | 2018-9-18 10:44:47 | 显示全部楼层
最后一课 留给脚印方便以后寻找吧
回复 支持 反对

使用道具 举报

wen1 | 2018-9-19 16:22:51 | 显示全部楼层
回复

使用道具 举报

本版积分规则